Analytics is showing wrong country. Please help fix.

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM – Analytics Analytics is showing wrong country. Please help fix.

This topic contains 9 replies, has 2 voices, and was last updated by Avatar eritechdeveloper 2 months, 3 weeks ago.

  • Author
    Posts
  • #129317
    Avatar
    eritechdeveloper
    Participant

    The analytics is showing all hits to the website is from the US, but we are in the UK. and have not published the site yet.

    Capture7

  • #130101
    Avatar
    Sushobhan
    Keymaster

    Hi,
    Thanks for getting in touch with us!
    It seems your Google Map Key is not authorized to use for this domain. You can check this error in your browser console (see here- https://imgur.com/FE7z5LA)
    That’s why it showing dummy results.
    Thank You!

  • #130145
    Avatar
    eritechdeveloper
    Participant

    Ok where do I update the API key to make this work, because the Google API key in the Geo search is working fine?

  • #130288
    Avatar
    Sushobhan
    Keymaster

    Hi,
    Google offers different API for different services. First, make sure you have added/enabled Google Maps API for your project. If it’s already enabled, then you will need to adjust the ‘API Restriction’ field. Read more on this from here- https://wordpress.org/support/topic/referer-not-allowed-map-error/
    Thank You!

  • #131407
    Avatar
    eritechdeveloper
    Participant

    Will try this and let you know. thanks

  • #131409
    Avatar
    eritechdeveloper
    Participant

    Hi Buddy,

    Thanks, but still not working, where do I have to input this API Key? because if the API key is not working the other maps on the website will not work, but as you will see in the admin dashboard the API is working fine buddy.

    Please take another look, thanks in advance.

  • #132152
    Avatar
    Sushobhan
    Keymaster

    Where you can see that in the “admin dashboard”?

  • #132176
    Avatar
    eritechdeveloper
    Participant

    Hey buddy, I saw it in settings -> Geo location tab. See picture below.

    <script async src=”//s.imgur.com/min/embed.js” charset=”utf-8″></script>

    https://imgur.com/a/sl2IVEh

  • #132402
    Avatar
    Sushobhan
    Keymaster

    Hi,
    Add the following line in your child themes functions.php or using code snippet plugin and wait for 7days-
    add_filter( 'wcfm_is_allow_wc_geolocate', '__return_false' );
    Thank You!

  • #132834
    Avatar
    eritechdeveloper
    Participant

    ok thanks, what was the problem?

You must be logged in to reply to this topic.