wcfm-santa

Celebrate Poila Baisakh with upto 25% off - A Fresh Start, A Great Deal!

Claim Offer
01Day 17Hrs 12Min 20Sec
wcfm-santa

Cannot add product after WP and Woocommerce update – JS errors

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WC Marketplace Cannot add product after WP and Woocommerce update – JS errors

Viewing 0 reply threads
  • Author
    Posts
    • #138195
      somedev
      Participant

      Hi guys!

      Firstly, I want to say Well Done for this plugin and thank you for offering it to the world.

      Now, down to the problem. The plugin was working fine. A few days ago I updated both WP and Woocommerce and after that everything seemed to work perfect until I tried to add a new product yesterday and it just didn’t do anything.
      I looked in the browser console and I saw there are quite a few JS errors.
      To be honest, I don’t know exactly if one or more of them were there before the updates, but I am certain that WCFM worked fine before, as I added a few products which were fine, so it makes sense that there is an incompatibility between the modules versions.

      Here are my installed versions:
      WP: Version 5.4.1
      WooCommerce: Version 4.2.0
      WCFM – WooCommerce Multivendor Marketplace: Version 3.4.0
      WCFM – WooCommerce Multivendor Membership: Version 2.9.0

      I attached 2 images for the Add product page result – one from a vendor user logged in and another one with the admin logged in, as there are different JS error as I noticed.

      Note: as you might notice, on the one with the Vendor user logged in, the product form is submitted, but it returns with all the fields in the URL (GET).
      I don’t know if that’s correct, but I presume it’s not, because when I tried to add a proper (a bit longer) product description, I got an error like “the URL is too long and cannot be processed”, so I presume that the form sends the data as POST, so that might be a helpful information.

      In any case, I would be so grateful if you can look into this, as I am sure a lot of othere people that probably didn’t discover this problem yet or are struggling to figure it out.

      Please let me know if I can help with anything or you need more information.

      Thank you very much for your support.

      Best regards,

      Andy.

      Attachments:
      You must be logged in to view attached files.
Viewing 0 reply threads
  • You must be logged in to reply to this topic.