wcfm-santa

We've turned 4! Celebrate with us and take away upto 30% off on WCFM Addons.

Claim Offer
03Day 10Hr 10Min 34Sec
wcfm-santa

Cannot display vendor registration form custom fields on the vendor store page

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM – Marketplace (WooCommerce Multivendor Marketplace) Cannot display vendor registration form custom fields on the vendor store page

Viewing 2 reply threads
  • Author
    Posts
    • #131012

      Hello there,

      I have created a vendor registration form custom field called Website where the vendor can store his affiliate website (see attached picture). I require that this new website field is displayed as part of the store info on the vendor store page. How could I achieve that please?

      P.S. I am using WCFM Elementor for creating the vendor store page and the store info widget to display the store’s information.

      Thank you in advance
      Regards
      Chris

      Attachments:
      You must be logged in to view attached files.
    • #131298

      Hello,

      add_action('wcfmmp_store_after_sidebar_info','fn_wcfmmp_store_after_sidebar_info_1505');
      function fn_wcfmmp_store_after_sidebar_info_1505($store_id) {
      	$custom_fields = get_user_meta( $store_id, 'website',true);
      	$field_name = 'Website';
      	echo $field_name.': '.$custom_fields;
      }

      Try this code to your child theme’s functions.php

      In case you do not have child theme then add code using this plugin – https://wordpress.org/plugins/code-snippets/

      Thanks.

    • #133135

      Hi,

      unfortunately this did not work. Another option how to achieve this?

      Thank you

      Attachments:
      You must be logged in to view attached files.
Viewing 2 reply threads
  • You must be logged in to reply to this topic.