CHANGES in WCFM Marketplace NOT GETTING SAVED

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM – Ultimate CHANGES in WCFM Marketplace NOT GETTING SAVED

This topic contains 23 replies, has 10 voices, and was last updated by Avatar CKENT 1 month, 1 week ago.

  • Author
    Posts
  • #136392
    Avatar
    Simona Paganetto
    Participant

    Hello WC Lovers Team,
    I hope you’re safe from the destruction of cyclone Amphan.

    We have bought all your PREMIUM ADD-ONS including ULTIMATE and the ZELLA WooCommerce compatible THEME. Please find here attached the versions and also WooCommerce Frontend Manager – Product Hub – Version 1.0.8

    We have noticed that most changes we do within the MARKETPLACE don’t get retained / DON’T GET SAVED by the Marketplace and they go back to the Default Settings. Or once a change has been made, it cannot be changed any more. The BASIC FUNCTIONALITY is simply not there.

    For example:

    PRODUCTS => VARIATIONS. THE single IMAGES of the variations go back to DEFAULT if you’re not changing all the variations at once. Even so, and you’re successful, if you go back to check the next day the VARIATION IMAGES go back to the DEFAULT IMAGE.
    PRODUCTS => INVENTORY => OUT OF STOCK. One product keeps going back in OUT OF STOCK, despite changing it to IN STOCK many TIMES.
    PRODUCTS => I had written TEST TEST in Product Policies Tab => Policy Tab Label. Then I went back to leave it blank and it doesn’t save changes.
    SETTINGS => COMMISSION SETTINGS => I had changed them to reflect my preferences (15% to VENDOR) and they got back to the DEFAULT SETTINGS.
    SETTINGS => PAYMENT SETTINGS => I had changed them to allow only PAYPAL & STRIPE, and they went back to allow also BANK TRANSFER, which I don’t want.
    When saving images on the Media Library, ALT TEXT is not always retained by the system, and when you select an image you have to re-write the ALT TEXT each time.

    These are just EXAMPLES, there are plenty of CHANGES that simply DON’T GET SAVED AT ALL.

    Please kindly let us know, how we can these major functionality issues. WE ARE CURRENTLY STUCK and cannot move ahead with the project.
    Looking forward to hearing from you.

    Many thanks in advance.

    Kind regards,
    Simona

    Attachments:
    You must be logged in to view attached files.
  • #136452

    I am having this issue too and have been experiencing it since the end of April. It has affected sales and giving a terrible user experience. We havent had any resolution with WCLover as of yet 🙁

  • #136456
    Avatar
    Simona Paganetto
    Participant

    Thank you Mary-Louise, at least I have a confirmation that’s a real issue for others too, I thought I was getting crazy and doing the same changes all over again… we haven’t even gone live yet and it’s a major basic functionality issue not being able to save changes properly. I’m really worried about this. Hopefully we’ll get an answer soon.

  • #136460
    Avatar
    Simona Paganetto
    Participant

    Sorry, one important question: are you by any chance using as well the ZELLA Nasa Theme? Or any other Nasa Theme? Just to exclude that these bugs might be related to the compatibility of these Themes. However, as you said before it was working fine and only since the end of April you started experiencing the same issues, I doubt that this is the case… Thanks for your reply.

  • #136469

    Hi Simon, no we are using the Woodmart theme from Envato. We have identified that changes default back to previous settings when another element is changed. For example when we make a change to vendors policies (in their store settings), their shipping settings then change – back to a previous, and incorrect setting. It has happened with stock levels and product descriptions too. We have to constantly check them. And can see on our recordings of website use that people are abandoning sales because of this. It’s really stressful.

  • #136482
    Avatar
    Simona Paganetto
    Participant

    Ok, many thanks for your reply. One more question to better understand where this issue is coming from. If before the end of April everything was fine, did you recently update the plugin? if yes, then we know the issue it with the recent version of the plugin. Thanks again for your reply.

  • #136566

    Hi Simona (sorry for spelling error above). No it started happening before we updated the plug in. We update the plug in, in case that fixed the bug, but it didnt. We have also turned off all caching, cleared transients even set up a staging server to replicate the site and test various things to see if we can isolate the setting that is making this happen – and we have not been able to work it out at all. We are not clueless eihther, our developer is very knowledgeable on WP sites and coding etc but we cannot work it out.
    One point to note is I dont actually know if this started at the end of April or earlier. But we launched our site at the end of April and so thats when we noticed it.

  • #136738
    Avatar
    pachinowebsite
    Participant

    ciao ragazzi, purtroppo anch’io ho notato questo problema, non fa riferimento alla fine di aprile ma tutto e iniziato a metà maggio, riscontrato il problema che non memorizzava i comandi richiesti. ho provato a disinstallare tutti i plugin che avevo installato, pensavo fosse un plugin in conflitto, ma nulla di questo ha risolto il mio problema. utilizziamo un thema acquistato su theme forest si chiama martfury e nei mesi precedenti funzionava tutto correttamente. Ho ricevuto un aggiornamento del thema, installato correttamente ma non ha risolto il problema su wc lover . i nostri clienti sono infuriati noi compresi. dov’è l’amministrazione per aiutarci a questo intervento ? se avete notizie condividedete. grazie

  • #136795
    Avatar
    surajspillai2015
    Participant

    Hi Team,

    Hope you are safe. Iam facing a similar isssue. None of the changes I make is being saved. I use rehub theme.

    Regards

  • #137150
    Avatar
    Simona Paganetto
    Participant

    Thank you very much for your comments everyone, they give us proof that this basic functionality bug is not related to the theme we are using or to the plug-ins we installed. I hope we’ll hear from the WC Lovers Team very soon, as I cannot launch my marketplace under these conditions, I’m currently stuck. The product is simply not working. Cheers

  • #137274

    Hi all
    Yes definitely not the theme as we took out all plugins and removed the theme on our staging site and left us with only woo commerce plug ins – and the issue was still there.
    I have emailed WPLovers, and posted on the forum but am getting no answer – anyone else getting anything?

  • #137326
    Avatar
    Simona Paganetto
    Participant

    Hi Mary-Louise, I’ve emailed them too, nothing so far, no response, I’ll write in here as soon as I receive any response.

  • #137550
    Avatar
    tgl
    Participant

    Just out of curiosity, what hosts are people using?

  • #137554
    Avatar
    Simona Paganetto
    Participant

    I’m using siteground.com currently in their GrowBig plan.

  • #138104
    WCFM Forum
    WCFM Forum
    Keymaster

    What happening if you are click on setting page “Save” button?

    Please check at wp-admin -> WooCommerce -> Status -> Logs -> fatal_erros log -> is any error generated?

    Also check in Google Chrome Browser console, is there any JavaScript error happening to the site or not!
    (What is browser console – https://support.airtable.com/hc/en-us/articles/232313848-How-to-open-the-developer-console)

  • #138182

    Thanks, here is some additional information to help you…

    We can duplicate the issue every time as follows:

    1) Using a single browser tab (Chrome or IE).
    2) Update shipping settings e.g change the cost of shipping > SAVE
    3) Refreshing the page shows shipping cost has saved correctly
    3) Make a change within Store Policies e.g add a word to the textbox > SAVE
    4) Refresh the page, Check the Store Shipping again and the shipping cost has changed!


    Errors seen on the Chrome Dev Console as soon as the Store Manager page loads (no extensons are running) are:

    (index):1 [DOM] Found 3 elements with non-unique id #vendor_id: (More info: https://goo.gl/9p2vKq) <input type=​”hidden” id=​”vendor_id” name=​”vendor_id” class=​”hidden” value=​”26″>​ <input type=​”hidden” id=​”vendor_id” name=​”vendor_id” class=​”hidden” value=​”26″>​ <input type=​”hidden” id=​”vendor_id” name=​”vendor_id” class=​”hidden” value=​”26″>​


    There are no errors in the Woocommerce logs.

    The above error happens even if we revert to the stock WordPress Theme and remove all non WC/WCFM plugins.

    We sent a video demonstrating the problem via email to your support desk on 20th May.

    Hope that helps.

  • #138212
    Avatar
    Didier Altamirano
    Participant

    I am getting the same error since updating to the latest version, could you fix it please

  • #139211
    Avatar
    Simona Paganetto
    Participant

    Hello WC Lovers Team,
    We checked the points you mentioned above. Below are our observations:

    1. Woocommerce Status Log – No error logs are found in the woocommerce >> status >> logs.

    2. Browser console: we don’t think any of these WC Lovers bugs related error is getting generated here as well. When we tried saving the product variation, attached is the screenshot of the browser console.

    There is an error of websocket which is visible in browser console throughout the website. In our opinion it is definitely not related to the WCFM Marketplace bugs. It is something related to the browser settings. So nothing useful found in the browser console as well.

    Our website launch is getting delayed because of these bugs, we hope this information is useful for your team, PLEASE kindly find a solution ASAP, as without solving these issues, we cannot move ahead. We are looking forward to hearing from you.

    Attachments:
    You must be logged in to view attached files.
  • #139445
    Avatar
    Brandon RIvers
    Participant

    The only answer they will ever give is to check the error log that never detects any savestate issues.

  • #141231
    WCFM Forum
    WCFM Forum
    Keymaster

    @simona Paganetto contact us from premium support.

  • #141495
    Avatar
    SSC
    Participant

    Interesting.. I too am experiencing save issues with the settings, but only ever since wcfm v6.5.0
    I see you are using v6.4.8, is this accurate?
    I am well-versed in coding and development but can not find any obvious errors.
    I was starting to think maybe it is a error with the new woocommerce version, but it works fine with woo v4.2.0 and wcfm v6.4.9
    I see you have a higher wcfm ultimate version, than the base version; I still don’t believe that is the issue though.
    For sure this is a head-banger. Do you have access to the server files? Are you able to view apache2 error logs?
    I have no errors anywhere…. really makes no sense why settings are no longer being saved for a lot of people…

  • #141499
    Avatar
    tgl
    Participant

    @SSC you are welcome to join an unofficial users group on FB:

    https://www.facebook.com/groups/users.of.wcfm.marketplace/

    Devs are a great resource!

  • #141501
    Avatar
    SSC
    Participant

    Cool, I’ll check it out.

  • #146181
    Avatar
    CKENT
    Participant

    I have some sections that do not save. Have you guys had any luck with getting this solved. For example my “Product Type Specific Category Setup” wont save no matter what I do. It acts like it then somehow gets cleared.

You must be logged in to reply to this topic.