Customers receive one email for each product shipped

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

From now the forum will be read-only!

This topic contains 4 replies, has 3 voices, and was last updated by WCFM Forum WCFM Forum 4 months ago.

  • Author
    Posts
  • #99480
    Avatar
    Paulette
    Participant

    Hello,
    I noticed that there are too many email notifications sent to my customers after ordering multiple products. I’m using WCFM marketplace

    – when the vendor marks the order as shipped on their dashboard, the customer receives a separate email for each product ordered (email subject: Shipment Tracking Update). If I order 10 items, I will receive 10 emails at the same time.
    – when the customer marks the product as received on their My Account page: how can I disable this email?
    – when the vendor marks the order as completed on their vendor dashboard, the customer receives a separate email for each product ordered (email subject: A note has been added to your order)

    I would like for my customers to receive only one email for the entire seller’s order when the order is marked as shipped or completed (if the customers order from 2 different sellers, then they would receive 2 different emails according to when the respective sellers change the order status). How I can do that?

    Also, there are typos in some emails (like in the Inquiry Reply email for instance), where can I change the content of the automatic emails?

    Thank you very much for your help!

  • #99710
    WCFM Forum
    WCFM Forum
    Keymaster

    HI,

    Please contact us here – https://wclovers.com/woocommerce-multivendor-customization/

    We will help you tweak these.

    Thank You

  • #121791
    Avatar
    SebastianFloKa
    Participant

    Hi,

    same here. I thought this issue was solved some time ago, see here:
    https://wclovers.com/forums/topic/several-order-completed-mail-per-order/

    I have following code in my functions.php:
    add_filter( 'wcfm_is_allow_itemize_notification', '__return_false' );

    But from EACH vendor updating his status it sends
    – ONE notification email for the whole order with a not correct translated text “#1962 order status updated to In Bearbeitung” (I could translate directly in the php-tempale myself –> no issue) –> this email is activated by above code snippet and not sent if above code snippet is deactivated –> fine.
    – ONE notification email for EACH item –> these should not be sent anymore but they are sent. –> ISSUE!

    So 10 products from 3 vendors end up in 13 notification emails for EACH order update.

    Actual completed-email in WooCommerce / Settings / E-Mail already deactivated otherwise there would be 14 emails. Did you do any modification in context with the provided code snippet?

    Order Sync is deactivated.

    I run current versions of WCFM Marcetplace, Ultimate, Membership, Groups & Staff,

    I already tested deactivating different plugins such as Germanized but this doesn’t influence the issue.

  • #121935
    Avatar
    SebastianFloKa
    Participant

    I tried a detour: Deactivate notification emails at WooCommerce / Settings / email – this means significantly less emails but no possibility to “leave a note to the customer”. OK for the moment.

    BUT if vendor adds the tracking code even by “update all items tracking info:”, still one email per item is sent (many many emails in total). And in case vendor would like to enter the tracking number only for a specific item, also not possible because only first item is visible (see attached picture).

    Anybody out there running WCFM without bombing customers with emails and can help?

    Attachments:
    You must be logged in to view attached files.
  • #132415
    WCFM Forum
    WCFM Forum
    Keymaster

    Please be sure you are using WCFM Ultimate version 6.4.10+

    Otherwise, this code will not work – add_filter( ‘wcfm_is_allow_itemize_notification’, ‘__return_false’ );

    You have to sync your translation file with latest WCFM Ultimate plugin files to have these new strings.

You must be logged in to reply to this topic.