wcfm-santa

A deal you can't resist! Get upto 35% Off on this entire cyber week.

CLAIM OFFER
00Day 03Hr 58Min 36Sec
wcfm-santa

Firebase Chat Doesn't Connect

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Tagged: ,

Viewing 4 reply threads
  • Author
    Posts
    • #125929
      Tyde
      Participant

      I just purchased Ultimate specifically for the Chat feature. But the setup for Firebase has changed and when entering the following from your setup guide:

      {
      “rules”: {
      “.read”: “true”,
      “.write”: “true”
      }
      }

      And

      || request.auth == null

      Both lines of code generate errors.

      Can you advise what the updated code should be.

      Thanks

    • #125955
      Tyde
      Participant

      Hi there, I figured it out and was able to connect. All good.

    • #134182
      Kenneth Wall
      Participant

      Hi i was having same issue, what did you do to fix?

    • #138355
      Kenneth Wall
      Participant

      Hi james, can you let me know what you did to fix it? I had same issue.

    • #138376
      Tyde
      Participant

      Hi Kenneth

      I chose the wrong type of firebase database and the data entry options didn’t match up with the WCLovers guide. Once I used the correct DB it went smoothly. The WCLovers documentation on the steps involved is spot on:

      https://docs.wclovers.com/live-chat-firebase-rules/

      Also watch out for:

      Quote: Step 8 : Add “|| request.auth == null” at the last in to the code

      Look at the screen shot – line 4: “allow read, write: if request.auth !=null || request.auth == null;

      In the default settings make sure the “:” is moved from after the first “null” to after the second “null”

      Good luck!

Viewing 4 reply threads
  • You must be logged in to reply to this topic.