How to change Quick Setup welcome message

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WC Vendors How to change Quick Setup welcome message

This topic contains 8 replies, has 3 voices, and was last updated by Avatar Sarmistha Chakraborty 1 month, 3 weeks ago.

  • Author
    Posts
  • #97815
    Avatar
    Ja’dan Johnson
    Participant

    I’d love to know how to change the quick setup text for vendors. I’d like to put my own message for this area.
    screenshot

    Attachments:
    You must be logged in to view attached files.
  • #97817
    Avatar
    Ja’dan Johnson
    Participant

    A next quick question would it be possible to also have the “Let’s go to the dashboard”
    button take users to the page to verify their account.

    And maybe a quick explanation how I can change some of the verbiage on the site (I tried LocoTranslate to no success).

  • #97877

    Hello,

    add_filter('wcfmmp_store_setup_steps','fn_wcfmmp_store_setup_steps');
    function fn_wcfmmp_store_setup_steps($default_steps) {
      $default_steps['introduction']['view'] = 'custom_wcfmmp_store_setup_introduction';
      return $default_steps;
    }
    function custom_wcfmmp_store_setup_introduction(){
    //change the text as your requirement
      ?>
        <h1><?php printf( __("Welcome to %s!", 'wc-multivendor-marketplace'), get_bloginfo('title') ); ?></h1>
        <p><?php printf( __('Thank you for choosing %s! This quick setup wizard will help you to configure the basic settings and you will have your store ready in no time.', 'wc-multivendor-marketplace'), get_bloginfo('title') ); ?></p>
        <p><?php esc_html_e("If you don't want to go through the wizard right now, you can skip and return to the dashboard. You may setup your store from dashboard &rsaquo; setting anytime!", 'wc-multivendor-marketplace'); ?></p>
        <p class="wc-setup-actions step">
          <a href="<?php echo site_url().'/store-manager/profile/#sm_profile_manage_form_verification_head'; ?>" class="button-primary button button-large button-next wcfm_submit_button"><?php esc_html_e("Let's go!", 'wc-frontend-manager'); ?></a>
          <a href="<?php echo esc_url(get_wcfm_url()); ?>" class="button button-large"><?php esc_html_e('Not right now', 'wc-frontend-manager'); ?></a>
        </p>
        <?php
    }

    Try this code to your child theme’s functions.php

    In case you do not have child theme then add code using this plugin – https://wordpress.org/plugins/code-snippets/

    Thanks.

  • #99841
    Avatar
    Ja’dan Johnson
    Participant

    Happy Holidays! Thank you for the support, i had another quick question — Is it possible for the verification to be moved to the quick setup that comes after you register? and some of our vendors told us that when they submit a product it just loads and doesn’t show a confirmation and each time they hit submit we get multiple requests for the same product. Thanks in advance.

    • #100028

      Hi,

      Is it possible for the verification to be moved to the quick setup that comes after you register?
      >> What we understand that you want to off “vendor verification” in vendor registration form. Then turn off the “Email Verification” from Store Registration Settings.(PFA)

      some of our vendors told us that when they submit a product it just loads and doesn’t show a confirmation and each time they hit submit we get multiple requests for the same product.
      >>Please check at wp-admin -> WooCommerce -> Status -> Logs -> fatal_erros log -> is any error generated?

      Also check in Google Chrome Browser console, is there any JavaScript error happening to the site or not! (What is browser console – https://support.airtable.com/hc/en-us/articles/232313848-How-to-open-the-developer-console)

      Thanks.

      Attachments:
      You must be logged in to view attached files.
  • #100171
    Avatar
    hindipogi
    Participant

    Hi, I have the same problem. I tried to add this to my child theme:

    add_filter(‘wcfmmp_store_setup_steps’,’fn_wcfmmp_store_setup_steps’);
    function fn_wcfmmp_store_setup_steps($default_steps) {
    $default_steps[‘introduction’][‘view’] = ‘custom_wcfmmp_store_setup_introduction’;
    return $default_steps;
    }
    function custom_wcfmmp_store_setup_introduction(){
    //change the text as your requirement
    ?>
    <h1><?php printf( __(“Welcome to %s!”, ‘wc-multivendor-marketplace’), get_bloginfo(‘title’) ); ?></h1>
    <p><?php printf( __(‘Thank you for choosing %s! This quick setup wizard will help you to configure the basic settings and you will have your store ready in no time.’, ‘wc-multivendor-marketplace’), get_bloginfo(‘title’) ); ?></p>
    <p><?php esc_html_e(“If you don’t want to go through the wizard right now, you can skip and return to the dashboard. You may setup your store from dashboard › setting anytime!”, ‘wc-multivendor-marketplace’); ?></p>
    <p class=”wc-setup-actions step”>
    ” class=”button-primary button button-large button-next wcfm_submit_button”><?php esc_html_e(“Let’s go!”, ‘wc-frontend-manager’); ?>
    ” class=”button button-large”><?php esc_html_e(‘Not right now’, ‘wc-frontend-manager’); ?>
    </p>
    <?php
    }

    Nothing change. I tried refreshing my browser and different browsers, nothing change.

    Please help mo too.

    Thanks and happy holidays.

  • #101074
    Avatar
    Ja’dan Johnson
    Participant

    Hi! I’m stil looking into the loading error – Will follow up with you however what I had meant is.

    Is it possible to move the verification to here (screenshot)

    Attachments:
    You must be logged in to view attached files.
    • #101110

      Hi,

      Is it possible to move the verification to here (screenshot)
      >> It’s not possible “verification” move to “let’s go” page.
      That’s why we have sent you the previous script for, “Let’s go” redirect to vendor profile “verification” page.

      Thanks.

You must be logged in to reply to this topic.