I click on reports but I am getting the booking tab

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM – Ultimate I click on reports but I am getting the booking tab

Viewing 27 reply threads
  • Author
    Posts
    • #127020
      Avatareritechdeveloper
      Participant

      Hi,

      as a store vendor, when I click report I am getting the booking tab, did I break it somehow.

      See image herenull

    • #127022
      Avatareritechdeveloper
      Participant

      Capture

    • #128503
      AvatarSushobhan
      Keymaster

      Hi,
      Thanks for getting in touch with us!
      Open your WCFM dashboard (admin user) >> Settings >> Menu Manager and expand the Reports menu. Check the url field, the value should be something like this – [Home url]/store-manager/reports-sales-by-date/.
      I think somehow this url field value gets changed to Booking menu URL.
      Let me know if this fixes your problem.
      Thank You!

    • #128546
      Avatareritechdeveloper
      Participant

      That works, but that whole menu manager is broken.

      Capture4

      I fixed a few, but it keeps breaking, do you know how I can avoid it?

    • #128711
      AvatarSushobhan
      Keymaster

      Are you saying it gets broken without you changing anything? Well, that’s odd!

      The Menu Manager is there to provide the admin, full control over Dashboard Menu. But if you don’t want to keep it under your settings page then I can provide you a code to hide it. Will that help?

      Let me know.
      Thank You!

    • #128842
      Avatareritechdeveloper
      Participant

      Correct, it happened again today, and I fixed it at least 2 or 3 times already. Without changing anything it keeps on breaking.

      Capture6

    • #129275
      AvatarSushobhan
      Keymaster

      Hi,
      It’s hard to tell what is causing this issue. It seems like a conflict with some other plugin or theme. Though if you want to disable this you can do so using the following line-
      add_filter( 'wcfm_is_pref_menu_manager', '__return_false' );
      Add this code to your child theme’s functions.php
      In case you do not have a child theme then add code using this plugin – https://wordpress.org/plugins/code-snippets/
      Let me know how this goes.
      Thanks!

    • #129316
      Avatareritechdeveloper
      Participant

      ok I will fix it on time, and disable the menu manager, I will do it now and let’s how it goes tomorrow.

    • #129320
      Avatareritechdeveloper
      Participant

      Nope still broken, please help me fix this asap.

    • #129906
      AvatarSushobhan
      Keymaster

      So you are saying you fixed the menu links, and then disabled menu manager. But it gets broken again!
      Would you be comfortable sharing temporary backend access of your site, along with site URL, to debug this further?
      When sharing the access, please don’t forget to mark the reply as private.
      Thank you!

    • #129996
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #130106
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #130132
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #130133
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #130134
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #130139
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #130151
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #130160
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #130161
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #130291
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #130987
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #131337
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #131402
      AvatarSushobhan
      Keymaster

      Hi,
      I have reset all the menu links. And it works perfectly. Also, disabled the snippet I provided you to hide the menu manager.
      Please check.
      Thank You!

    • #131408
      Avatareritechdeveloper
      Participant
      This reply has been marked as private.
    • #133889
      Avatareritechdeveloper
      Participant

      This issue is back again, soon as I try to enable the withdrawal tab in the menu manager.

      Capture<br />photo uploader<br />

    • #134567
      AvatarSushobhan
      Keymaster

      Hi,
      Can you please tell me if you are still facing this issue? As I can see Withdrawal tab is already enabled and it isn’t messing up with the menu. If possible send me a screen recording of how I can reproduce this.
      Thank You!

    • #136288
      Avatareritechdeveloper
      Participant

      Hi Subshobhan, sorry to hear about the cyclone.

      I have actually disabled the menu manager, for now, using your snippet to stop it from breaking again.

    • #139060
      Avatareritechdeveloper
      Participant

      This is becoming a real headache, every time I disable code snippet to debug an issue. This menu issue reappears because menu manager is enabled again. Can you help me get a permanent fix?

Viewing 27 reply threads
  • You must be logged in to reply to this topic.