Image limit not working

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Viewing 17 reply threads
  • Author
    Posts
    • #117165
      AvatarHenriette
      Participant

      Hi

      Ik have a question about Image limit is Groups & Staff.
      Is this limit per product or for the whole gallery?
      I tried both but vendor can still add as many images as he wants although he is assigned to this group.
      I have Ultimate too.
      Please see attachment.

      I also have another question about shipping. I will ask in the right forum.

      Attachments:
      You must be logged in to view attached files.
    • #117560
      AvatarSushobhan
      Keymaster

      Hi,

      Thanks for getting in touch.
      ‘Gallery Limit’ is applied per product. So if in your group capability you set the value as 2, then all the vendors in that group will be able to add at max 2 gallery images to each of their products.
      Please recheck your vendor group settings and let me know if the problem persists. In that case I might require a temporary access to check all the settings. When sharing the access, please don’t forget to mark the reply as private.

      Thanks!

    • #118669
      AvatarHenriette
      Participant

      Hi, sorry for my late reply.

      I have checked the group setting and vendor is granted to 1 image in Gallery Limit.
      But it gets even stranger.
      I have set product image on mandatory in WCFM Admin (just this morning).
      Now when a vendor ads just one image by clicking on the big placeholder and than wants to submit his product he gets an error that gallery image is required.
      When vendor leaves the big placeholder blank and submits his image with the little image placeholder the product gets published.
      When vendor adds image first with big placeholder and than with little placeholder he can publish his product and both images are shown in store.

      Please see attachment.

      Attachments:
      You must be logged in to view attached files.
    • #118672
      AvatarHenriette
      Participant

      Please let me know what Email I can use to give you backend access as a test vendor.

      • #118740
        AvatarSushobhan
        Keymaster
        This reply has been marked as private.
    • #118739
      AvatarSushobhan
      Keymaster

      Hi,
      Featured image and Gallery images are different from one another. The “big placeholder” image is for Feature image and down below the smaller ones are for gallery. I believe you have made only Gallery image mandatory and that’s why you are getting this behavior.
      Thanks!

    • #118957
      AvatarHenriette
      Participant

      Hi,
      I do not have an option to set gallery image mandatory on Admin settings > Product Custom Validation. In your language file it is translated as “Aanbevolen afbeelding” which means “Recommended Image” in my language.
      After searching for the translation I found this in Frontend Manager Ultimate where it says “Featured image”. Anyway, that problem is solved now because setting Main (big) image as required was my intention.

      But Gallery limit still isn’t solved.
      On Trial/Free Membership I want to let vendor only publish one image along with the product (the featured/main/big one.)
      But vendor can still add another image from gallery and it will be published too.

      Things I’ve tried:
      1] In general admin settings > Capability I also set Gallery Limit to 0. I also tried -1. So I thought with other plans/groups I could set image gallery on a higher number.
      2] In Groups setting with assigning free membership vendor to it I tried Limit Gallery: 0. But when saving the settings it jumps back to “Unlimited”. I tried also in Groups to set to -1 but that doesn’t work either.
      Vendor can still add more images than one. No matter what I try.

      Please see attached images.
      As you can see not all is translated by me yet but I think it must be clear for you what I mean. Otherwise feel free to ask.

      Thank you.

      Attachments:
      You must be logged in to view attached files.
    • #119109
      AvatarSushobhan
      Keymaster

      Hi,
      Under capability, count 0 signifies – unlimited.
      Now as you want to disable gallery for a vendor group, go to group capability and under “Sections” turn off Gallery Image. That’s it! Easy-peasy 🙂
      Thanks!

    • #120011
      AvatarHenriette
      Participant

      Hi,

      Well not so Easy-peasy as you mentioned.
      Now vendor can not upload an image at all.
      I just want vendor to upload one -featured- image and not a second one.
      Please see attachments. Translations come from your plugin so maybe that’s why I can not find it.

      Attachments:
      You must be logged in to view attached files.
    • #120044
      AvatarSushobhan
      Keymaster

      Hi,
      It’s been going back and forth for quite sometime. I want to thank you for keeping your patience.
      To solve the issue quicker, could you please provide me an access of your site (admin and vendor). The settings I told you should work but for you, it’s not.
      When sharing the details please don’t forget to mark the reply as private.
      Thanks!

    • #120046
      AvatarHenriette
      Participant

      Hi Sushobhan,

      For making an Admin en Vendor account I need an Email address for you.
      Can you please tell me which Email I can use to make you an Account for backend access?

    • #120052
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #120059
      AvatarHenriette
      Participant
      This reply has been marked as private.
    • #120069
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #120073
      AvatarHenriette
      Participant
      This reply has been marked as private.
    • #120076
      AvatarHenriette
      Participant
      This reply has been marked as private.
      • #120100
        AvatarSushobhan
        Keymaster

        Hello,
        As I can see you have WCFM Groups & staffs plugin installed. And there you have 2 groups Zilver and Proefpakket. When a vendor is assigned a group then, group capability supersede the default vendor capability. Right now two vendors are assigned under Proefpakket, so to set their capability you will need to go to Groups page from WCFM dashboard and click on the group name or the corresponding pencil icon under ‘Actions’ column.
        Once you are in the edit screen, go to Capabilities section and and made your changes. Like based on your requirement I enable Featured Image (Aanbevolen afbeelding) and disbale Gallery image (Geef de hoogte van de afbeeldingsgalerie aan.). I don’t know about these translations, if they are not right then you can use a plugin called Loco translator to change them according to your need.
        So now your vendors Bertjes and Jetjes should have Featured image enabled(the big one) and no gallery images.
        Please check and let me know.

    • #120078
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #120083
      AvatarHenriette
      Participant
      This reply has been marked as private.
    • #120114
      AvatarHenriette
      Participant

      Thank you so much! I will try this weekend.
      For now I won’bother you again.
      If it doesn’t work I will post it.
      Also when it’s solved.

      The translation comes from your plugin.
      Since you have backend access you can see that I already have translated a lot with Loco Translate.
      Look at your plugin translation files and you’ll see a lot of red (fuzzy?) in the original files.

      I don’t know about these translations, if they are not right then you can use a plugin called Loco translator to change them according to your need.

      But sometimes it does not find the Dutch language string in Loco.
      Therefore I have to look for it in Notepad++ (searching the phrase in all language files) on my local computer.

      “Geef de hoogte van de afbeeldingsgalerie aan” in Dutch means: “Specify the height of the image gallery”. That is totally different than “disable Gallery image” what it is supposed to be according to you.

      With all due respect and the translator of the Dutch files meant undoubtedly well but for me it is more confusing than leaving it in English.
      And for the plugins that are not translated in Dutch: I don’t know any of these languages.
      So I definitely need the English strings to translate any of these files.
      It took me for 6 weeks now to translate 80% what I did already thanks to Notepad++

      So that is why I don’t understand so many things (besides my newbee-ness to WP)

      Anyway… for now thank you very much for your time.
      I will let you know if your solution worked.
      Have a nice weekend!

      Attachments:
      You must be logged in to view attached files.
Viewing 17 reply threads
  • You must be logged in to reply to this topic.