Plugin overloads server – CPU max. out

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Viewing 22 reply threads
  • Author
    • #113432

      Hi WC Lovers!

      First time I am setting up a market place with WCFM and i really like what it does.
      My site is ready to go now and I just found out that the plugins consumes a lot of server resources. I am on Siteground GoGeek plan and it pushes the CPU over the limit – and that is just me setting up the site and testing – nothing else.

      This is one example of what’s happening:

      There is a huge number of /wp-admin/admin-ajax.php request as my host points out: (the 25.000 requests are not evenly spread out over 24 hours).

      So basically, when I start working in the backend, the CPU just skyrockets.

      I am not sure how well this forum is attended, I have posted before but never got an answer, but I really hope someone can help out with this.
      I spent the last days trying to fix this and I had a developer look over this, but he couldn’t help either. If I don’t get this fixed I will unfortunately need to use another plugin, since I finally want this site up and running next week.

      Thanks a lot!

      P.S. This is a site, I just started out with, so haven’t purchased ultimate yet – maybe that’s why support is not responding?

    • #113577
      Mostafa Kandil

      I have many issues with my site performance many files and requests slow down my whole site
      I don’t know how to fix that, and i am not sure if it’s fixable

    • #113579

      Thanks for the reply! Yes, that really sucks… The plugin looks really good but at this point I am thinking of going with a different one. It would make things so much better if it were possible to limit those server requests, I don’t need to get instant notifactions via the browser for new messages and stuff like that…

    • #113648

      I have the same problem, a big load on the server

    • #114227

      Same problem here, the shop becomes totally unusable after minutes of rebooting the instance.

      If this is not fixed by the following hours I’ll must migrate to dokan.

    • #114265

      I see this forum very active here and the developers very helpful, but this issue is not being addressed and there is no response at all on this.

      Have a look at this and guess when WCFM was opened (I am not talking about actually working on it, just some admin tabs being idle):
      10 minutes before 11am I started the computer, some tabs where open and you see how high it climbed within that hour. It makes it practically unusuable, my websites would get blocked and me kicked off the server.

      My host told me it’s due to the high number of admin-ajax.php requests (every 6 seconds with WCFM to see if there are new messages) –
      When I asked them if a VPS would solve this issue their response was and I quote: “It is quite possible that your server VPS server to reach high load due to these requests.”

      I believe it would be solved by eliminating these requests if all push-notifications are turned off. I have updates set only via e-mail, so admin and vendor only gets the updates via e-mail and not life notifications. Or give the option to delay the requests and make them every minute (I even think 5 minutes are ok). I just don’t see it sustainable if idle tabs are making that many requests – even I just playing around went beyond server limit (it’s shared hosting yes, but it’s not the worst).

      I am playing around WC Marketplace for now and I don’t have that issue with that plugin. So that might be an option.

      For now I only hope they are willing to share a code snippet to stop the requests. It would be a shame if the plugin is unusuable “just” because of this. But I am in the same boat as you @nacho: I need to hear that this issue will be solved otherwise I need to unfortunately look elsewhere.

    • #114266

      Exactly, a code snippet deactivating all push-notification would probably be the solution. Only mail and our shops would be online and making revenue.

      I have it on AWS Lightsail instance and it’s a shame this plugin cannot run after all the configuration and time we spent on it.

      If Ultimate upgrade would fix this, I’ll buy it instantly. Or just a code snippet.

    • #114267

      Yeah, that sucks, I am in the same situation – have it all set up and happy until I realized it cannot be used. I would upgrade to ultimate as well, and I definitely will, if I get this thing to run. But I highly doubt it will fix it – maybe make it worse with more options.

      Everyday I am on the fence of jumping boat, but then decide to just give them more time to look into this with the hope they will.

      At this point I am just waiting for any kind of clear answer. If it’s a “no, sorry guys, can’t do that” at least we know. But no answer is a bit frustrating.

    • #114273

      Has anybody tried unchecking EVERY pop-up notification on Adjusts->Notifications?

      Any improvement over admin-ajax.php calls?

    • #114297

      yes, i have done that. no success.

    • #114315

      Just to follow up as I’m loosing money and need to fix this urgently:

      Heartbeat API plugin: set to 150, same result
      UpdraftPlus plugin: deactivated: same result

      Disable WP-Cron and set a manual cron job on the server, just in case.

      Bunch of errors: [Tue Mar 31 12:17:59.454580 2020] [proxy_fcgi:error] [pid 23xx:tid 1403752xxxx] [client xx.xx.xx.xx:43152] AH01071: Got error ‘PHP message: woocommerce_get_price is deprecated since version
      3.0.0! Use woocommerce_product_get_price instead.’, referer:

      Disabling Jetpack just in case.

      Any ideas?

      Will keep you posted.

    • #114323

      I disabled wp-cron as well and set up a real cron job twice a day. I tried to disable the heartbeat completely – issue is the same. I tried to deactivate ALL plugins except Woocommerce, the 3 WCFM plugins and Limit heartbeat to disable the heartbeat – it’s all the same.

      I see WCFM is not tested with the new Woocommerce version – maybe that’s a reason?

      One question: Why do you think Updraft Plugin could be causing this?

      @wcfmforum can you please update us on this if there is any intention to address this issue?

    • #114545

      I have tried on a fresh new install, just woocommerce, wcfm plugins and limit heartbeat installed – the issue is with the frontend dashboard, if that is deactivated it’s all normal, once activated it goes through the roof.

      On the same install I activated WC Marketplace, that worked just fine. It seems like the issue cannot be resolved, so I guess the only thing to do is just rebuilt the whole site.

    • #114615

      Same here, it seems to be the Frontend.
      It’s driving us nuts.
      As soon as 50 people enters at the same time, CPU goes ballistic.

      So this error plus the pagination/filter errors, we’re seriously thinking to migrate our 300 vendors to other platform, even manually.
      It does not make sense to spend loads of money on resources than are drained by wcfm 🙁

    • #114616

      Yes, and imagine some of these vendors are like me and open a few tabs at once, leave them open for days, or just open their laptops and each and every tab is draining your server – without the site refreshing or anything.

      I have only seen small stores with WCFM, so my guess is, that’s fine for that, especially if the vendors aren’t online all the time. But I really need something where a tab once loaded doesn’t consume constant resources, very simple. It doesn’t make sense to me why you would ruin an otherwise great product this way. They say the requests can’t overload the server, but it’s a fact that once the frontend plugin is activated the problem comes up (admin-ajax requests or not, but it’s the plugin anyway).

      I had a developer looking over this, he couldn’t determine what is causing the overload. He told me to rename the admin-ajax.php file and see what will happen.
      Well, I did just this the past hour and this is the result: (same issue, plugin is unusable).

      WC Lovers doesn’t seem to have a solution to this, nor they seem to care much. So that means for me tomorrow I am going to work on the switch. @nacho have you another preference? I have tested Product Vendors and WC Marketplace today, so far I liked WC Marketplace best.

    • #114618

      @alexdezi We’re going to try Dokan Business. We have great plans but we’re on a budget. We gave wcfm the opportunity, thinking on upgrading to Ultimate and get the App too, but it’s not worth our time fixing stuff and our money on servers that could be used by the NASA to put us back into the Moon.

      We’ll have a look to your recommendations too, thanks for the tips.

      It’s a shame that what could be a great product stay like a product for small/very small shops, not to mention the claim “All we want is love. […] post it in the support forum, and we will respond within 6 hours(during business days).”

      Time is money and I have lost massive loads of time 🙁

    • #114632

      LOL, yeah, the it has been more like waiting for 2 weeks 🙂 good luck with your project!

    • #114725
      Molay Das


      Sorry for the delay.
      This seems to be a issue from your server end. Did you inform it to your server admin about it? It can also happen due to low server bandwidth, maybe you need to upgrade your hosting plan.
      Please contact your server admin first and do let us know what they said.


    • #114731

      Yes, I was in touch with the server host. The site is hosted on Siteground GoGeek – the highest plan for shared hosting. I asked if an upgrade to VPS would solve the issue, they said for that amount of requests that’s probably not the solution. I just open a few tabs – leave them idle, I don’t do anything at all on any of the sites and leave them open and the server usage increases like crazy. I have done that over night, where none of the sites are accessed and it only happens if the frontend plugin is activated. This is also on a fresh new install – default theme, no other plugins, just WCFM, Woocommerce and Limit Heartbeat – it’s every time the same issue.

    • #116181

      Hi there! I have the same problem, how can I disable ajax calls? With the new update it doesnt allow me to open the configuration page.

    • #121273

      Thanks for getting in touch and sorry for any inconvenience caused.
      Earlier the plugin checks for any new notifications every 1 min. But now we have disabled the feature by default. Please update to our latest version, v3.3.8 and this issue will be resolved.

    • #123934

      Having the same issue here, even having version 3.3.8. CPU use is out of control and the website is really slow.
      We need a solution fast!

    • #124098
      Molay Das

      Hi @Oriol Pujols Domenech,

      The notification checking for every min has been disabled by default in version 3.3.8 so it may be due to some other plugins installed in your site.
      Please check your browser console and you may also try this plugin to check this issue:


Viewing 22 reply threads
  • You must be logged in to reply to this topic.