problem with Analytics

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

  • This topic has 10 replies, 2 voices, and was last updated 2 years ago by hani.
Viewing 10 reply threads
  • Author
    Posts
    • #73097
      sdel_nevo
      Participant

      Hi Guys

      looking at analytics captured by your plugin, I can’t work out what’s happening

      it appears that the IP address details and country are incorrect

      Steve

    • #73098
      sdel_nevo
      Participant
      This reply has been marked as private.
    • #73184
      sdel_nevo
      Participant
      This reply has been marked as private.
    • #73413
      sdel_nevo
      Participant

      Hi Guys

      I have been in touch with my host, they have confirmed that everything is configured correctly their end, they are unsure as to why the analytics plugin is recording data incorrectly.

      Any chance you could take a look at this for me.

      I can provide admin details to my site if required

      Steve

    • #73660
      sdel_nevo
      Participant

      Hi Guys

      I have attached two images

      1 is the analytics from my network, the other is from google analytics

      this covers the same date range (last 7 days)

      you can see the problem

      your plugin records everything as either the UK or Malta

      Steve

      Attachments:
      You must be logged in to view attached files.
    • #73838
      sdel_nevo
      Participant

      Hi Guys

      just replied to your e-mail

      I added

      add_filter( ‘wcfm_is_allow_wc_geolocate’, ‘__return_false’ );

      to my functions file, the IP addresses are now being recorded correctly

      however the country, state and city are incorrect

      I’m being recorded as the USA when I’m in the UK

      my mobile is recorded as France, also in the UK

      I use wordfence to protect my site, could that be the issue

      Steve

    • #73869
      sdel_nevo
      Participant

      Hi Guys

      as advised in another e-mail I cleared out all references of wcfm_user_location from the user-meta table

      now sometimes when I visit the site(when not logged in) it records correctly both the IP address and Location
      if I revisit later (also not logged in) it records incorrectly

      Steve

    • #73933
      sdel_nevo
      Participant

      Hi guys

      I have an odd issue with the analytics, this is effecting both wordfence and your analytics plugin

      The United States is being shown as united countys

      If I disable my theme it shows correctly in both plugins

      I’m using the flatsome theme and have some code in my functions file

      Would you be able to see if you can see what the issue is?

      If this is ok, I will send you the access detail

      I would be most great full

      Steve

    • #73938
      sdel_nevo
      Participant

      Hi Guys

      I have found the problem code.

      I added this in my Functions file to change “State” to “County on the vendor pages

      // Change state to county on vendor pages
      function wcfm_marketplace_custom_address_field( $address_fields ) {
      if( isset( $address_fields[‘state’] ) ) {
      $address_fields[‘state’][‘label’] = ‘County’;
      }
      return $address_fields;
      }
      add_filter( ‘wcfm_marketplace_settings_fields_address’, ‘wcfm_marketplace_custom_address_field’ );
      add_filter( ‘wcfm_membership_registration_fields_address’, ‘wcfm_marketplace_custom_address_field’ );
      add_filter( ‘wcfm_wcmarketplace_settings_fields_customer_support’, ‘wcfm_marketplace_custom_address_field’ );

      function wcfm_custom_2406_translate_text( $translated ) {
      $translated = str_ireplace( ‘State’, ‘County’, $translated );
      return $translated;

      add_filter(‘gettext’, ‘wcfm_custom_2406_translate_text’);
      add_filter(‘ngettext’, ‘wcfm_custom_2406_translate_text’);

      unfortunately, this was also changing “United States” to “United Countys” in wordfence and your analytics plugin

      do you know how this code can be changed to prevent this

      Steve

    • #73956
      sdel_nevo
      Participant
      This reply has been marked as private.
    • #127072
      hani
      Participant

      Hi,

      I have exactly the same problem, showing london city in store list searching page automatically (Wrong). and showing UK in analytics.

      would you you share the solution if you have it?

Viewing 10 reply threads
  • You must be logged in to reply to this topic.