wcfm-santa

A deal you can't resist! Get upto 35% Off on this entire cyber week.

CLAIM OFFER
00Day 02Hr 50Min 26Sec
wcfm-santa

Recaptcha issue

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Tagged: ,

Viewing 6 reply threads
  • Author
    Posts
    • #71874
      fernandobrenes
      Participant

      Hi WC Lovers,

      Thank you for this great plugin.

      I have installed the plugin suggested: https://wordpress.org/plugins/advanced-nocaptcha-recaptcha/

      And as I mentioned here: https://wclovers.com/forums/topic/install-google-recaptcha/ it only uses v2_checkbox_script() instead of invisible recaptcha.

      Is it possible to fix this?

      Also, language is not detected properly.

      I notice 2 problems:

      1. For the language in vendor_registration.php line 400

      <?php
      $lang = ”;
      if ( $language ) {
      $lang = “&hl=$language”;
      }
      ?>

      It needs to be changed to:

      <?php
      $language = trim( anr_get_option( ‘language’ ) ); < ===== Without this language is not set
      $lang = ”;
      if ( $language ) {
      $lang = “&hl=$language”;
      }
      ?>

      For the second issue about invisible recaptcha: class-wcfmvm-frontend.php on line 876

      $size = anr_get_option( ‘size’, ‘normal’ ); <==== v2_checkbox is hardcoded

      Since I’m using invisible recaptcha I modified to use ‘size’:’invisible’ However, I believe it should be worth to fix both issues for future releases 🙂

      Thank you!

    • #72267
      WCFM Forum
      Keymaster

      HI,

      Thanks for the details, we will definitely take care of this in coming update.

      Thank You

    • #84894
      GilbertW
      Participant

      Hi


      @Fernando
      : Thanks for pointing this out. I have the same kind of issues here:

      1. I selected “V2 invisible” captcha from advanced captcha no recaptcha plugin settings, and I still get the V2 Check Box.
      2. I selected “Hide Captcha for logged in users?” in the advanced captcha no recaptcha plugin settings, and I still get the V2 Check Box for logged in user, for example in the support box.


      @wclover
      : I’m using the latest releases and I still have the issues. Could you please kindly fix this? Thanks!

    • #86186
      WCFM Forum
      Keymaster

      Will do this.

    • #90195
      JuanB
      Participant

      Hi, is this problem solved?
      I have all the updated add-ons, but I have the same problem.
      Thank you

    • #91110
      WCFM Forum
      Keymaster

      NO, these captcha options not yet added!

      We will do this in coming update.

    • #132580
      CAM
      Participant

      Is this working now?

      Cannot see any recaptcha information in documentation.

Viewing 6 reply threads
  • You must be logged in to reply to this topic.