Skip shipping for bookable products

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Viewing 7 reply threads
  • Author
    Posts
    • #128047
      Avatareritechdeveloper
      Participant

      Hi,

      I tried skipping shipping for bookable products using this.

      add_filter( ‘wcfm_pm_block_class_shipping’, function( $attr_block_classes ) {
      return ‘simple variable’;
      });

      But I am still getting an error.

      I also want to remove the delivery location, map and ship to a different address in the checkout page.

    • #128100
      Avatareritechdeveloper
      Participant

      Please also help me in renaming Billing & Shipping to Billing details

    • #128294

      Hello,

      skipping shipping for bookable products using this.
      add_filter( ‘wcfm_pm_block_class_shipping’, function( $attr_block_classes ) {
      return ‘simple variable’;
      });
      But I am still getting an error

      >>Kindly share us the error, and Modify the code-

      add_filter( 'wcfm_pm_block_class_shipping', function( $attr_block_classes ) {
      	$attr_block_classes = 'simple variable';
      	return $attr_block_classes;
      },15);

      I also want to remove the delivery location, map and ship to a different address in the checkout page.
      >>For this we have add this “Shipping By Distance” feature in our latest update, incase you do not need it, you can turn off this module.(PFA)
      and to hide ship to a different address in the checkout page make sure that Force shipping to the customer billing address checkbox is checked.(Administration->Woocommerce->Settings->Shipping->Shipping Options)

      Please also help me in renaming Billing & Shipping to Billing details
      >>Please use Loco Translate plugin for changing text. As you know this page appearing from WooCommerce.
      https://wordpress.org/support/topic/rename-billing-shipping-header/
      https://dessky.com/snippet/change-billing-address-label-woocommerce-checkout-page/

      Thank You

      Attachments:
      You must be logged in to view attached files.
    • #128372
      Avatareritechdeveloper
      Participant

      I am still seeing shipping by vendor, below the subtotal and it is still asking me to select a shipping option when I checkout.

      That setting was never enabled.

      Is there another way to translate without loco translate, I find it hard to use.

    • #128402

      Hello,

      If you do not want shipping option then please check you have disabled the “Shipping location(s)” from WooCommerce->Settings->General (PFA)

      Is there another way to translate without loco translate, I find it hard to use.
      >>The best and easiest solution is Loco translate(https://localise.biz/wordpress/plugin/beginners)
      Otherwise your can override “form-billing.php” file in your theme “yourtheme/woocommerce/checkout/form-billing.php” from “\wp-content\plugins\woocommerce\templates\checkout” and change the text.

      Thanks.

      Attachments:
      You must be logged in to view attached files.
    • #128404
      Avatareritechdeveloper
      Participant

      Thanks for disabling the shipping from the subtotal, but I still see the delivery location and map as per the image below

      Capture3

      I will try overriding billing.php and let you know.

    • #128407

      Hi,

      Make sure “Checkout User Location” is unchecked – Wcfm Dashboard -> Settings -> Geo location

      Thanks.

      Attachments:
      You must be logged in to view attached files.
    • #128414
      Avatareritechdeveloper
      Participant

      That is it, thank you.

Viewing 7 reply threads
  • You must be logged in to reply to this topic.