Spinning wheel on Direct Message

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Viewing 3 reply threads
  • Author
    Posts
    • #122273
      contact8732
      Participant

      Hello, when Vendor tries to send Direct Message to Admin from Vendor Store Manager Announcements page, the message sends but the spinning wheel continues and an error is shown in google chrome inspect console:

      Uncaught TypeError: Cannot read wcfm-script-messages.js?ver=6.4.8:44 property ‘setContent’ of null
      at Object.success (wcfm-script-messages.js?ver=6.4.8:44)
      at i (jquery.js:2)
      at Object.fireWith [as resolveWith] (jquery.js:2)
      at x (jquery.js:4)
      at XMLHttpRequest.c (jquery.js:4)

      Thank you

      Attachments:
      You must be logged in to view attached files.
    • #122462
      Sushobhan
      Keymaster

      Hi,
      This seems like a plugin conflict. Kindly disable all other plugins except WooCommerce and WCFM plugins. After that you can enable rest of the plugins one by one to find out the cause.
      one query – Did you disabled rich editor option for your vendors, from Capability settings?
      Let me know how it goes.
      Thanks!

    • #122474
      contact8732
      Participant

      Rich editor was disabled. When I enable it, the problem disappears ­čÖé Thank you. I would like Rich Editor to be disabled – is there a way you can make it so Direct Messages work without spinning wheel when Rich Editor disabled please? (Same problem also happens for Vendor replies to Admin announcements).

    • #122499
      Sushobhan
      Keymaster

      Hi,
      The WP rich editor library(tinymce) some how gets initiated here. It shouldn’t be, as you have disabled that feature. I believe there might be some other plugin producing this conflict.
      You can try using the following hack to bypass this. This code is untested as I couldn’t replicate the issue on my side, but it should work.

      add_action('wcfm_main_contentainer_after', function() {
          $rich_editor = apply_filters( 'wcfm_is_allow_rich_editor', 'rich_editor' );
          $wpeditor = apply_filters( 'wcfm_is_allow_product_wpeditor', 'wpeditor' );
          if( ! $wpeditor || ! $rich_editor ) {
           ?>
          <script>
              setTimeout(function(){
                  window.tinymce = void 0;
              },0);
          </script>
          <?php
          }
      });

      Add this code to your child theme’s functions.php
      In case you do not have child theme then add code using this plugin – https://wordpress.org/plugins/code-snippets/
      Let me know how this goes.
      Thanks!

Viewing 3 reply threads
  • You must be logged in to reply to this topic.
    Glastrennw├Ąnde
    blumen verschicken Blumenversand
    blumen verschicken Blumenversand
    Reinigungsservice Reinigungsservice Berlin
    k├╝chenrenovierung k├╝chenfronten renovieren k├╝chenfront erneuern