Stripe Signup Error during Vendor Wizard

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Viewing 5 reply threads
  • Author
    • #78097

      Hi All –

      Have WCFM Marketplace installed on my website for multi vendor marketplace. Having trouble configuring Stripe for payout use. I have the Client ID, the Live and Secret keys. Have followed all instructions in the docs. Still there is error.

      When new vendor is taken through vendor wizard, under “Payment Setup” there is “Connect with Stripe” Button. When it is clicked this error message appears:

      “error”: “invalid_redirect_uri”,
      “error_description”: “Invalid redirect URI ‘\u0026step=payment’. Ensure this uri exactly matches one of the uris specified in your application settings”,
      “state”: “21”

      I have tried multiple URIs to try to solve, including the one listed above in quotes. What is going wrong?

    • #78940
      WCFM Forum


      You have to redirect URL at Stripe account.

      Please go though this for setup details –

      Thank YOu

    • #79386

      Clearly you are not understanding or simply not reading what I wrote because my issue is that the URL/URI redirects I have specified are returning an error message. The error message is pasted in my first

      On our Stripe account under Stripe Connect “Integration”,

      Redirects Tried:\u0026step=payment

      All three of the above URIs have also been added to the Stripe Webhooks “Endpoints receiving events from Connect applications” as well, since I saw in another forum that another customer solved their error issue by adding them to that section.

      With every one of these attempts, the error message still presents. Why do you think that is? There is no further literature in the link you posted on this issue.

      Brian Kimble

      You must be logged in to view attached files.
      • #79558

        I had the same problem, luckily I found the solution.

        This is the exact URL you have to use as a redirects setting in Stripe, it’s the only way it will work:

        If you copy-paste the URL from the Stripe error message, it will fail due to that ‘\u0026’ character conversion bug on their side.
        If you copy-paste the URL from your actual website, it will also fail due to the trailing slash issue. – stripe doesn’t accept this because of the slash after .com .

        The main problem is that any instructions for this are completely missing from the wcfm plugin, so this will be broken for every single install by default, and the solution is pretty non-intuitive.

        Dear wclovers devs, please help your customers and let them know about this!

    • #79628
      WCFM Forum


      Really sorry for that. We will definitely mentioned this in documentation clearly.

      Thank You

    • #80223

      Thank you @me for this solution, I plugged your recommended link into both the “Webhook Endpoint” and the “Connect Redirect URI” on my Stripe account and now it is working fine.

      One note though: when I copy and pasted the link, it autocorrected the “&” into “& amp ;” and for some reason it would not work until I changed it back to “&”. This is probably something that most people know about, but for a n00b like me I didn’t notice it for a while, so just thought I would mention it.

      please update or add this to the Vendor Registration docs. Thanks.


    • #80228
      WCFM Forum


      Require “redirect urls” are given at WCFM Admin Setting -> Payment Setting –

      Thank You

Viewing 5 reply threads
  • You must be logged in to reply to this topic.