**URGENT/SITE CRASHING** Need help with AJAX calls/FrontEndManager

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM Marketplace – REST API **URGENT/SITE CRASHING** Need help with AJAX calls/FrontEndManager

Viewing 13 reply threads
  • Author
    Posts
    • #119882
      Avatarmxlocker.com
      Participant

      Hello, currently we are using multivendor marketplace, WC frontend manager and it is causing a huge amount of AJAX calls causing the site to crash, eat up CPU, etc.

      Please look at the video below, any help would be appreciated!

      https://wpengine-ss.s3.amazonaws.com/2020-04-16_10-33-08.mp4

      Attachments:
      You must be logged in to view attached files.
    • #119963
      AvatargazArchitect
      Participant

      up vote

      I am interested in this answer as I have seen runaway admin-ajax.php on our server requiring it to be bounced. Unfortunately, in production there is no time to keep debugging so we are limited only to the event logs related to the crash.

    • #120107
      AvatarSushobhan
      Keymaster

      Hi,
      Thanks for getting in touch and sorry for any inconvenience caused.
      By default the plugin checks for any new notifications every 1 min. Now, to solve the issue, either we can increase the time interval or disable auto update of notification feature. Let me know which option suits you and I’ll guide you accordingly.
      Also, as I can see there are 2 more topics you have created regarding the same issue. I’m closing those, as we will continue the discussion here.
      Thanks!

    • #120268
      AvatarSushobhan
      Keymaster

      Hello,
      Please update to our latest version, v3.3.8, there it is disabled by default.
      Thanks!

    • #120561
      AvatargazArchitect
      Participant

      I would like to see both paths to modifying admin-ajax if you could show. I can see use case for both solutions. Thank you.

      /side question: I am not able to create a new issue here in boards. Is creating new part of premium?/

    • #121280
      AvatarSushobhan
      Keymaster

      Hello,
      You can use the following filters to enable or disable this feature (v3.3.8 or above)-

      add_filter( 'wcfm_is_allow_desktop_notification', '__return_false' );
      add_filter( 'wcfm_is_allow_new_message_check', '__return_false' );

      To change the default time interval between requests, use the following filter-
      apply_filters( 'wcfm_new_message_check_duration', 60000 )

      You mentioned “I am not able to create a new issue here in boards.”, does this mean you can’t create new forum topics? Our forum is open for both our free and premium users. Please try using another browser or browser incognito mode.
      Thanks!

    • #121641
      AvatargazArchitect
      Participant

      Excellent. Thank you for the reply. I will implement these.

      Thank you also for reply to issue posting. Yes, I was not able to create a new topic under REST API forum. I was able to reply to existing topic feeds just not create new. I tried with Chrome per your advice and that worked. FYI Firefox 75.0 (64-bit) was the browser that failed on create new topic.

    • #122114
      AvatargazArchitect
      Participant

      I left 5 stars ;o) Will follow on twitter too. TY

    • #122148
      AvatarSushobhan
      Keymaster

      Thank You 🙂

    • #130018
      AvatarOksana Grishchenko
      Participant

      Hello

      How can disable checks for any new notifications every 1 min for vendors but at the same time it works for admin?

      Thank you

    • #130025
      AvatarSushobhan
      Keymaster

      Hi,
      You can use the following code to do that-

      function allow_only_for_admin( $status ) {
          if ( current_user_can( 'administrator' ) ) return true;
          return false;
      }
      add_filter( 'wcfm_is_allow_desktop_notification', 'allow_only_for_admin' );
      add_filter( 'wcfm_is_allow_new_message_check', 'allow_only_for_admin' );

      Add this code to your child theme’s functions.php
      In case you do not have a child theme then add code using this plugin – https://wordpress.org/plugins/code-snippets/
      Let me know how this goes.
      Thanks!

    • #134814
      Avatarciccupio97
      Participant

      How can i allow system to check for new notification to all vendors every 10 minutes?

    • #134818
      AvatarSushobhan
      Keymaster

      Hi,
      Kindly use the following filter for that purpose-

      add_filter( 'wcfm_is_allow_desktop_notification', '__return_true' );
      add_filter( 'wcfm_is_allow_new_message_check', '__return_true' );
      apply_filters( 'wcfm_new_message_check_duration', 600000 );

      Add this code to your child theme’s functions.php
      In case you do not have a child theme then add code using this plugin – https://wordpress.org/plugins/code-snippets/
      Let me know how this goes.
      Thanks!

    • #134867
      Avatarciccupio97
      Participant

      thank’s work fine

Viewing 13 reply threads
  • You must be logged in to reply to this topic.