Vendors unable to connect Stripe accounts

WooCommerce Multivendor Marketplace – Home Forums WCFM – Membership Vendors unable to connect Stripe accounts

This topic contains 14 replies, has 2 voices, and was last updated by WCfM Forum WCfM Forum 3 months ago.

  • Author
    Posts
  • #26470

    Kristin

    I have the latest version of WC Marketplace as well as the most recent versions of all WCFM plugins.

    My vendors are no longer able to connect to their Stripe accounts (it was working previously). They can go through the connection process as usual but when the system tries to return them to their WCFM dashboard, the page doesn’t load correctly (see screenshot here: https://www.dropbox.com/s/nqpgqcwxs4p7nqj/Screen%20Shot%202018-07-17%20at%208.10.00%20AM.png?dl=0). If they reload the page, it still shows PayPal as their chosen payment method and when they choose Stripe, it still shows their Stripe account as not connected. This occurs even if you click “Save” before reloading the page.

    I have double-checked that the URI is set as dictated in the WC Marketplace settings (https://icreatemarketplace.com/wcfm/settings/#wcfm_settings_form_payment_head). I have also double-checked the Stripe client ID, live publishable key and secret publishable key for my site Stripe account. I didn’t find anything in the Woocommerce error log.

    (I thought I posted this a while ago but then couldn’t find the post… sorry if you find a duplicate in another thread.)

  • #26472
    WCfM Forum
    WCfM Forum
    Keymaster

    Hi,

    Give me few minutes.

    I am checking this and let you know.

    Thank You

  • #26473
    WCfM Forum
    WCfM Forum
    Keymaster

    Hi,

    Kindly know me one thing, is that account connected to the Stripe properly? Did you checked that at Stripe account?

    Do one more thing, set redirect URL just this – https://icreatemarketplace.com/wcfm/settings/
    Without hash(#)

    Thank You

  • #26475

    Kristin

    If I don’t use the Redirect URI provided by WC Marketplace, I get this error message:

    {
    “error”: “invalid_redirect_uri”,
    “error_description”: “Invalid redirect URI ‘https://icreatemarketplace.com/wcfm/settings/#wcfm_settings_form_payment_head’. Ensure this uri exactly matches one of the uris specified in your application settings”,
    “state”: “36”
    }

    I’m not clear on which account you’re referring to when you ask if it’s connected to Stripe properly… my site Stripe account or the vendor? The site Stripe account is configured, both thru the WC Marketplace dashboard and thru Woocommerce. (In tests, it is able to accept payments through the Marketplace via Woocommerce.) The vendor’s account is not yet connected.

  • #26476
    WCfM Forum
    WCfM Forum
    Keymaster

    HI,

    Use this as Redirect URL at Stripe Account – https://icreatemarketplace.com/wcfm/settings/

    Thank You

  • #26477

    Kristin

    I tried that and it doesn’t work – when the vendor tries to connect, they get the error message I pasted in my previous reply.

  • #26478

    Kristin

    Are you referring to the Redirect URI or a webhook endpoint URL for Connect accounts? The setting I’m referring to is the Redirect URI, which is specified in the WC Marketplace payment settings.

  • #26480
    WCfM Forum
    WCfM Forum
    Keymaster

    HI,

    Please follow this – https://ibb.co/foE0wy

    Thank You

  • #26481

    Kristin
  • #26482
    WCfM Forum
    WCfM Forum
    Keymaster

    Yeah right, just use CONFIG REDIRECT URL – https://icreatemarketplace.com/wcfm/settings/

    Without hash part

    Thank You

  • #26483

    Kristin

    If you’re talking about the Redirect URI settings on the page shown here (https://www.dropbox.com/s/0n34xlsxv77s9pi/Screen%20Shot%202018-07-17%20at%2010.27.27%20AM.png?dl=0), the URL you keep giving me doesn’t work – the vendors get the following error message when they try to connect.

    {
    “error”: “invalid_redirect_uri”,
    “error_description”: “Invalid redirect URI ‘https://icreatemarketplace.com/wcfm/settings/#wcfm_settings_form_payment_head’. Ensure this uri exactly matches one of the uris specified in your application settings”,
    “state”: “36”
    }

  • #26484

    Kristin

    Just a note in case you didn’t notice – WC Marketplace updated their plugin today. It is that version I’m using (3.1.2) and having the issues with.

  • #26496
    WCfM Forum
    WCfM Forum
    Keymaster

    HI,

    Kindly try once with updated WCfM.

    Thank You

  • #26498

    Kristin

    It seems to be working now … thanks!

  • #26542
    WCfM Forum
    WCfM Forum
    Keymaster

    Great 🙂

The topic ‘Vendors unable to connect Stripe accounts’ is closed to new replies.