View groups: /vendor-groups/ redirects to homepage

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM – Groups & Staffs View groups: /vendor-groups/ redirects to homepage

Tagged: ,

Viewing 22 reply threads
  • Author
    Posts
    • #133034
      AvatarCAM
      Participant

      Please see attached image.

      When in shop-manager/groups/, clicking on any of the View icons (/vendor-groups/) redirects to homepage.

      I have looked in;

      * Settings > Dashboard Pages (cannot see anything for /vendor-groups)
      * Settings > Groups & Staffs (cannot see anything for /vendor-groups)
      * /wp-admin/options-permalink.php (cannot see anything for WCFM)

      Please advise.

      Thanks

      Attachments:
      You must be logged in to view attached files.
    • #133046
      AvatarCAM
      Participant

      This is a big problem for me because there is no way for me to see what Vendors are in what Groups…

      I have also tried viewing Settings > Store Vendors: however when I open a Vendor, it does not tell me if they are in a Group.

    • #133078
      AvatarCAM
      Participant

      I can confirm I have tried the Health Check Troubleshoot app and the problem still exists with following theme and plugins active:

      * Twenty Twenty

      * WCFM – WooCommerce Frontend Manager – Groups & Staffs
      * WCFM – WooCommerce Frontend Manager – Ultimate
      * WCFM – WooCommerce Frontend Manager
      * WCFM – WooCommerce Multivendor Marketplace
      * WCFM – WooCommerce Multivendor Membership
      * WooCommerce

      See screenshot attached.

      Attachments:
      You must be logged in to view attached files.
    • #133090
      AvatarSushobhan
      Keymaster

      Hi,
      Visit Settings >> Permalinks page and send me a snapshot of this page. As your problem is related to permalinks, it might get fixed only by visiting this page.
      Let me know.
      Thank You!

      • #133095
        AvatarCAM
        Participant
        This reply has been marked as private.
    • #133106
      AvatarSushobhan
      Keymaster

      Your settings seem alright to me. It’s very strange though.
      Please try to perform the following steps and after each step check if it solves the issue-
      1. Clear all shorts of cache, server cache, CDN cache. Once done, visit your Permalinks page (Settings >>Permalinks).
      2. Deactivate and activate WCFM plugins.
      3. Enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there. https://codex.wordpress.org/Debugging_in_WordPress
      4. Check your server log for any possible errors
      Thank You!

    • #133143
      AvatarCAM
      Participant

      1. Clear all shorts of cache, server cache, CDN cache. Once done, visit your Permalinks page (Settings >>Permalinks).
      – Done & Done
      2. Deactivate and activate WCFM plugins.
      – Done & Done – no change. Also cleared cache etc again.
      3. Enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there.
      Done– not sure exactly what looking for (will attach log in next private reply)
      4. Check your server log for any possible errors.
      DoneI can’t see anything that jumps out. What should I be looking for? Is there anything I should ask host? (www.liquidhost.com – Woocommerce specialists)

      This problem seems specific to /vendor-groups/ and I think it has existed since install (ie. I have never been able to visit these URLs).

    • #133145
      AvatarCAM
      Participant
      This reply has been marked as private.
    • #133146
      AvatarCAM
      Participant
      This reply has been marked as private.
    • #133172
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #133182
      AvatarCAM
      Participant
      This reply has been marked as private.
    • #133218
      AvatarSushobhan
      Keymaster
      This reply has been marked as private.
    • #133219
      AvatarCAM
      Participant
      This reply has been marked as private.
    • #133221
      AvatarCAM
      Participant

      When I disable “WCFM – WooCommerce Frontend Manager – Groups & Staffs” and visit /vendor-groups/ I get a 404 (as expected).

      When I enable it, /vendor-groups/ redirects to homepage.

    • #133441
      Avataremmagrimberg
      Participant

      I have the same problem….

    • #133466
      AvatarCAM
      Participant
      This reply has been marked as private.
      • #134774
        AvatarSushobhan
        Keymaster
        This reply has been marked as private.
    • #134775
      AvatarSushobhan
      Keymaster

      Hi @emmagrimberg,
      Are you still facing this issue? Please visit wp-admin >> Settings >> Permalinks page and then try again.
      Let me know if the problem persists.
      Thank You!

    • #135623
      AvatarCKENT
      Participant

      I am having this issue as well. It has never worked.

    • #135626
      AvatarSushobhan
      Keymaster

      Hi,
      Thanks for getting in touch with us!
      Do you have a staging site where we can debug this? As, we couldn’t be able to replicate this on our side.
      Let me know.
      Thank You!

    • #135944
      AvatarCKENT
      Participant

      I actually only have the main site right now. Do not have a staging site set up. We have not gone live yet but I will try to get you access later.

      I have gone through all of the above steps to see if any of that would fix it, nothing helps. I will note that there are no WCFM settings in the permalinks page. Just the standard stuff.

    • #136000
      AvatarCKENT
      Participant
      This reply has been marked as private.
    • #136052
      AvatarSushobhan
      Keymaster

      Hello,
      The password isn’t working. Please make sure you save the user after generating a new password. You can also try to login using those credentials just to be sure that it works.
      Looking forward to helping you.
      Thank You!

      • #136058
        AvatarCKENT
        Participant
        This reply has been marked as private.
        • #136074
          AvatarSushobhan
          Keymaster
          This reply has been marked as private.
    • #136073
      AvatarSushobhan
      Keymaster

      Hi,
      It’s working fine on my end. So it must be an issue of your browser cache. Please clear your browser cache and cookies and try again. You can switch to another browser or incognito mode to confirm this.
      Thank You!

      • #136167
        AvatarCKENT
        Participant

        I have tried on 5 different browsers, (firefox, edge, chrome, opera, and IE), cleared all cache, flushed DNS Cache tried another login, that same one you did, it does not work. Clicking on any of the view buttons (the eyeball) that are supposed to go to /vendor-groups/ does not work it redirects to homepage. There is no way that is working on your end.

    • #136171
      AvatarSushobhan
      Keymaster

      Hi,
      Sorry, previously I thought you can’t access the Groups page. I didn’t realize it was the /vendor-groups/ links. I have tested and able to replicate it on my end. It will be gets fixed in our next update.
      Thank You and Sorry for the additional trouble!

Viewing 22 reply threads
  • You must be logged in to reply to this topic.