WC Subscriptions "Validate email" function not working when WPML is active

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WC Subscriptions WC Subscriptions "Validate email" function not working when WPML is active

Viewing 2 reply threads
  • Author
    Posts
    • #115208
      Avatarhansa.tienda
      Participant

      Hi ,
      I Have WPML active along with WPML Woocommerce Multilingual.

      When the plugin “WPML Woocommerce Multilingual” is active , Im unable to use the “Validate email” for subscrition option.
      When i put an email in the subscription form the “code sending” fails and i get the following fatal error in the logs:


      2020-04-04T00:15:35+00:00 CRITICAL Uncaught Error: Call to a member function get_id() on int in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-emails.php:395
      Stack trace:
      #0 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-emails.php(375): WCML_Emails->get_email_translated_string('subject', Object(WCFMvm_Email_Email_verification), NULL)
      #1 /opt/bitnami/apps/wordpress/htdocs/wp-includes/class-wp-hook.php(289): WCML_Emails->filter_emails_strings('[{site_title}] ...', Object(WCFMvm_Email_Email_verification), '[{site_title}] ...', 'subject')
      #2 /opt/bitnami/apps/wordpress/htdocs/wp-includes/plugin.php(206): WP_Hook->apply_filters('[{site_title}] ...', Array)
      #3 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce/includes/emails/class-wc-email.php(490): apply_filters('woocommerce_ema...', '[{site_title}] ...', Object(WCFMvm_Email_Email_verification), '[{site_title}] ...', 'subject', '[{site_title}] ...')
      #4 /opt/bitnami/apps/wordpress/htdocs/wp en /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-emails.php en la línea 395

      As soon as i disable the WPML Woocommerce multilingual the form starts working normally.
      It seems that the language is not being passed correctly for some reason to the underlaying WPML function.

      Thanks

    • #115542
      WCFM ForumWCFM Forum
      Keymaster

      Hi,

      Please go to wp-admin -> WooCommerce -> Setting -> Emails -> WCFM – Email Verification – please check is this properly setup, specially subject and heading? https://ibb.co/0FS3r0f

      Thank You

    • #130780
      AvatarSushobhan
      Keymaster

      Hello,
      The same bug is discussed here-
      https://wpml.org/forums/topic/uncaught-error-call-to-a-member-function-get_id-on-array-in-class-wcml-emails-2/
      and
      https://wpml.org/forums/topic/uncaught-error-call-to-a-member-function-get_id-on-array-in-class-wcml-emails/#post-5835849
      As per WPML-

      Please note, this issue is fixed and the fix will be included in the upcoming version of the WooCommerce Multilingual 4.9.0.

      If version 4.9.0 is not released yet, you can try the first link, there they have provided a temporary fix.
      Looking forward to helping you.
      Thank You!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.