WCFM – WooCommerce Multivendor Marketplace Breaking Brazilian Checkout Fields

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM – Marketplace (WooCommerce Multivendor Marketplace) WCFM – WooCommerce Multivendor Marketplace Breaking Brazilian Checkout Fields

Viewing 8 reply threads
  • Author
    • #83616
      Cap Luis

      There is a plugin that adds fields specific to Brazilian users, such as personal identification number, better known in our country as CPF.

      This plugin searches national databases and confirms that the CPF is valid.

      The problem is that the field that must be filled in with the number! does not open automatically when wcfm market is active. It should be opened at checkout as soon as the page is loaded, yet I manually select it to have the field appear in the form. This field can be filled with multiple test zeros.

      When everything is correct, and WCFM Market DISABLED, I get the following message when I fill several zeros.

      CPF IS INVALID (This is perfect should be because I entered an incorrect number)

      This is good as it indicates that the field is working perfectly! and I must enter a suitable number, but when WCFM is activated, the field simply displays the message that it needs to be filled in as it is a required field! I can put the perfect document number, I can put several zeros, and the only thing the form says, is that I need to fill in because it is a required field, even if I have it filled, with a valid number or not.

      Not filling in this field, I cannot finalize the purchase!

      To identify the error I disabled all the plugins, and I was enabling the ones I need to identify the error, and to my surprise it was the wcfm marketplace that generated this friction.

      How can you reproduce this error!

      enable Brazilian Market plugin on WooCommerce

      Go to woocommerce ► checkout fields ► in the first option drop down make sure option 2 is selected (Natural person and legal person)

      Now put a product in the cart and go to checkout! At checkout you should see the option.

      Or should not see in this case. the field CPF.

    • #83617
      Cap Luis
      This reply has been marked as private.
    • #83956
      WCFM Forum


      Do you have enabled “WCFM Wirecard” gateway?

      Is this happening after enabling that? As that gateway form also have “CPF” number!

      Thank You

    • #84035
      Cap Luis

      I just disabled the wirecard and the plugin’s CPF field is still conflicting. I can’t tell if it’s the wirecard’s fault.

      Disabling WCFM marketplace works very well.

    • #84040
      Cap Luis

      Found it

      I disabled the “wirecard wcfm” option on the backend this had no effect, but I went to marketplace settings, payment methods and disabled WIRECARD.

      And the CPF field of the Brazilian plugin has returned to work!

      This has to be verified as 100% of Brazilian woocommerce use this plugin for checkout fields.

    • #84041
      Cap Luis

      Of course it should mark wirecard to give conflict, hopefully this does not happen in an active store as it blocks checkout and can give a lot of headache to an active site.

    • #84429
      WCFM Forum

      We will take care of this in next update!

    • #84692
      Cap Luis

      Any prevision?

    • #86107
      WCFM Forum

      It’s already resolved in WCFM Marketplace 3.2.3

Viewing 8 reply threads
  • The topic ‘WCFM – WooCommerce Multivendor Marketplace Breaking Brazilian Checkout Fields’ is closed to new replies.