Woocommerce wholesale prices – allow vendors to add wholesale customers

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WCFM – Feature Request Woocommerce wholesale prices – allow vendors to add wholesale customers

This topic contains 3 replies, has 2 voices, and was last updated by WCFM Forum WCFM Forum 2 weeks, 1 day ago.

  • Author
    Posts
  • #104377
    Avatar
    prashantd2011
    Participant

    I am using “Woocommerce wholesale prices” plugin. Now vendors can assign wholesale prices for products. But they can not add wholesale customers for their store.
    How to allow vendors to add wholesale customers? Because admin can not add wholesale customers one by one for all the vendors. So vendors themselves should be able to do that.
    My suggestion is that:
    If “Woocommerce wholesale prices” plugin is integrated with WCFM and when vendor is adding new customer,
    their should a checkbox like “Mark as wholesale customer”.
    When vendor checks this checkbox, an additional role of “Wholesale Customer” should be applied to that customer by keeping primary role “Customer” unchanged.
    This way we can make sure, in case “Woocommerce wholesale prices” plugin is disabled/deleted that customer will have access as a normal customer.

  • #105714
    WCFM Forum
    WCFM Forum
    Keymaster

    Hi,

    What is your whole sale customer users’ role?

    Thank You

  • #106050
    Avatar
    prashantd2011
    Participant

    What is your whole sale customer users’ role?
    Ans- Role is Wholesale Customer.
    Please Note:
    If vendor marks customer as a “Wholesale Customer”, additional role of “Wholesale Customer” should be applied by keeping main role as “Customer” unchanged.
    Because vendors should be able to add both type of customers, i.e. wholesale or retail customer, as per their business need.

  • #106442
    WCFM Forum
    WCFM Forum
    Keymaster

    Please contact us here – https://wclovers.com/setup-guidance/

    We will help you to setup this.

    Thank You

You must be logged in to reply to this topic.