2 way Google Calendar sync not working

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WC Appointment 2 way Google Calendar sync not working

Viewing 3 reply threads
  • Author
    • #68055


      As mentioned in the other thread, this 2-way-sync feature of the Appointments plugin doesn’t seem to work with WCFM. Several of your customers seem to be struggling with this.

      It works from vendor to google, but not from google to vendor. In other words, available slots don’t get blocked based on the vendor’s google calendar.
      After discussions with the plugin developers, it seems to be caused by the fact that they implemented this based on staff member roles only.
      They aren’t dealing with the concept of a vendor on their side.
      Direct quote from their support:
      “Do your Vendor users have also the Shop Staff member roles? If not, try adding them”

      Here is the complete discussion about it in their support forum:

      Best would be if you could talk to each other directly in order to resolve this.

    • #68099

      Quick update: I also managed to confirm through the WooCommerce logs that calendar syncing does in fact happen both ways, but the user is assumed to be a staff member. The new availability rules that were created according to the logs never show up in the vendor’s product settings, and are also ignored in the booking process. This definitely seems to be a WCFM issue, the WC Appointments plugin seems to work fine.

    • #68100

      Hi Mate

      I was just about to put an update here, but you beat me to it.


    • #76131

      Do you have any solutions for this?
      Please don’t ignore these threads.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.