How to disable adding vendor to notification emails?

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WC Appointment How to disable adding vendor to notification emails?

This topic contains 2 replies, has 2 voices, and was last updated by Avatar me 2 months, 3 weeks ago.

  • Author
    Posts
  • #93704
    Avatar
    me
    Participant

    Hi,

    WCFM Ultimate automatically includes vendors in some emails sent to customers. For example, appointment cancelled emails get sent to the vendor and customer all at once. I want to disable this. In /core/class-wcfmu-wcappointments.php : 79 there is a hook that does this. I can’t disable or override it no matter how I try. Can you give me a snippet or any other method to stop the wcfm_filter_appointment_emails() function from running? I commented it out in your base code for now but that is a very bad solution.

    Thanks.

  • #94042
    WCFM Forum
    WCFM Forum
    Keymaster

    HI,

    Please add this lines to your site –

    add_filter( 'wcfm_is_allow_new_appointments_vendor_notification', '__return_false' );
    add_filter( 'wcfm_is_allow_cancel_appointments_vendor_notification', '__return_false' );

    Add this code to your child theme’s functions.php
    In case you do not have child theme then add code using this plugin –¬†https://wordpress.org/plugins/code-snippets/

    Well, this will work after WCFM Ultimate next update.

    Thank You

    • #94052
      Avatar
      me
      Participant

      Thanks a lot!
      Could you also help me with my other question regarding Stripe Checkout? You keep replying “this will only work with single orders, are you ok with that?” and then stop responding when I say yes.

The topic ‘How to disable adding vendor to notification emails?’ is closed to new replies.