Registration on WCFM not working –

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Multi Vendor Marketplace Plugin | WCFM Marketplace Forums WC Vendors Registration on WCFM not working –

Tagged: 

Viewing 35 reply threads
  • Author
    Posts
    • #136216
      AvatarDavo McConville
      Participant

      Hello,

      I have an issue – when I click “Login-Register” and try to Register a new user, it does not do the WCFM registration process

      How do I make the Register button go to the WCFM registration / dashboard?

      Thanks

      !!

    • #136217
      AvatarDavo McConville
      Participant
      This reply has been marked as private.
    • #136436

      Hello,

      Please check the vendor registration documentation here – https://wclovers.com/knowledgebase/wcfm-marketplace-vendor-registration/
      Default registration form(WooCommerce registration form) used for customer registration.
      You will find Vendor registration page contain “[wcfm_vendor_registration]” shortcode.

      Thanks.

    • #136465
      AvatarDavo McConville
      Participant

      Hello Sarmistha – I have done all this correctly, but registration still does not lead to WCFM

      Can you help me today please? Thanks!

    • #136468

      Hello,

      Have you check the pages in your WordPress dashboard? Is there any page with this “[wcfm_vendor_registration]” shortcode? If not kindly create a page with this “[wcfm_vendor_registration]” shortcode and browse it. You will find the Vendor registration form.

      Thanks.

    • #136476
      AvatarDavo McConville
      Participant

      Hello yes that page is set, with this short code:

      [sc name=”wcfm_vendor_registration”]

      The page is named “Register” – is this correct?

      • #136485

        What is this? – [sc name=”wcfm_vendor_registration”] ??
        We have mentioned you the shortcode is – [wcfm_vendor_registration]
        PFA

        Attachments:
        You must be logged in to view attached files.
    • #136477
      AvatarDavo McConville
      Participant
      This reply has been marked as private.
    • #136480
      AvatarDavo McConville
      Participant
      This reply has been marked as private.
    • #136484
      AvatarDavo McConville
      Participant

      To be clear, what I want out of this is:

      • All Sign ups to the site create users who are buyers AND vendors

      • All users need to be approved

      • email verification

      Thanks

    • #136512
      AvatarDavo McConville
      Participant

      OK I have changed the Register page to

      [wcfm_vendor_registration]

    • #136515
      AvatarDavo McConville
      Participant

      The page now works, thank you!

      However, when I click:

      Login/Register in my header, then “Register” – it does not correctly go to this page ([wcfm_vendor_registration])

      Can you help

    • #136520
      AvatarDavo McConville
      Participant

      Another issue:

      When I register a new Vendor through [wcfm_vendor_registration], their default role is “None”, not “Vendor”

      Can you tell me where to modify this?

    • #136521
      AvatarDavo McConville
      Participant

      Actually registration to WCFM still isn’t working

      The latest vendor I registered through [wcfm_vendor_registration] does NOT show in WCFM Store Manager

    • #136547

      Hello,

      Login/Register in my header, then “Register” – it does not correctly go to this page ([wcfm_vendor_registration])
      >> This is your theme’s login/register form. Yes it will not open “Vendor registration” form here. You can add “Become vendor” link in after the header register form .

      function custom_wcfmmp_become_vendor_link() {
      	global $WCFM, $WCFMmp;		
      		$hide_become_vendor = wcfm_get_option( 'wcfmvm_hide_become_vendor', 'no' );		
      		if( apply_filters( 'wcfm_is_allow_my_account_become_vendor', true ) && ( $hide_become_vendor !== 'yes' ) && WCFMmp_Dependencies::wcfmvm_plugin_active_check() ) {
      			if( wcfm_is_allowed_membership() && !wcfm_has_membership() && !wcfm_is_vendor() ) {
      				echo '<div class="wcfmmp_become_vendor_link">';
      				$wcfm_memberships = get_wcfm_memberships();
      				if( apply_filters( 'wcfm_is_pref_membership', true ) && !empty( $wcfm_memberships ) && apply_filters( 'wcfm_is_allow_my_account_membership_subscribe', true ) ) {
      					echo '<a href="' . apply_filters( 'wcfm_change_membership_url', get_wcfm_membership_url() ) . '">' . apply_filters( 'wcfm_become_vendor_label', __( 'Become a Vendor', 'wc-multivendor-marketplace' ) ) . '</a>';
      				} else {
      					echo '<a href="' . get_wcfm_registration_page() . '">' . apply_filters( 'wcfm_become_vendor_label', __( 'Become a Vendor', 'wc-multivendor-marketplace' ) ) . '</a>';
      				}
      				echo '</div>';
      			}
      		}
      }

      When I register a new Vendor through [wcfm_vendor_registration], their default role is “None”, not “Vendor”
      >>There is no “None” role in WordPress. If you turn-on “Required Approval” functionality for vendor registration, then by-default vendor will be registered as a “subscriber” role.

      The latest vendor I registered through [wcfm_vendor_registration] does NOT show in WCFM Store Manager
      You/admin have to approve vendor from “Notification dashboard” then it will display in “Store Vendors” in WCFM dashboard.(https://h7j7p1zzlnf3ejiqd3k68ivc-wpengine.netdna-ssl.com/wp-content/uploads/2018/08/wcfmmp_registration_approve.png)

      Thanks.

    • #136549
      AvatarDavo McConville
      Participant

      Hello, no – the last vendor who registered does not appear in Store Vendors.

      Please can you look at my site and help me specifically?

      Can the theme’s Login/Register be directed to [wcfm_vendor_registration]?

    • #136555
      AvatarDavo McConville
      Participant

      What should these settings be in WooCommerce?

      Attachments:
      You must be logged in to view attached files.
    • #136634
      AvatarDavo McConville
      Participant
      This reply has been marked as private.
    • #137231

      Hello,

      Regarding vendor who registered does not appear in Store Vendors,
      Kindly provide us your site admin access(username/password), then we can check this. (Set as private reply)

      Can the theme’s Login/Register be directed to [wcfm_vendor_registration]?
      >>We have already replied you in this #136547 thread.

      What should these settings be in WooCommerce?
      >>Please check the WooCommerce Settings documentation here – https://docs.woocommerce.com/document/configuring-woocommerce-settings/

      Thanks.

    • #137232
      AvatarDavo McConville
      Participant

      Hello – so to be clear, there is NO way for:

      Login/Register (WooCommerce link) to direct to [wcfm_vendor_registration]

      I need this functionality. Can you suggest a workaround?

    • #137233
      AvatarDavo McConville
      Participant
      This reply has been marked as private.
    • #137234
      AvatarDavo McConville
      Participant

      Hi – when I asked what the settings in WooCommerce should be – so to use WCFM, the settings should be the WooCommerce default?

    • #137391

      Hello,

      WooCommerce Login/Register goes to [wcfm_vendor_registration]
      >>You must be aware our WCFM plugin has not any customization in WooCommerece registration form. So, Vendor registration via WooCommerce registration form is not possible using code snippet.
      It requires serious custom development, and this will be a paid one.
      Please be advised then normal-user/customer not able to register in your site. All users will be vendors.

      the settings should be the WooCommerce default?
      >>Yes

      Thanks.

    • #137392
      This reply has been marked as private.
    • #137395
      AvatarDavo McConville
      Participant
      This reply has been marked as private.
    • #137396
      AvatarDavo McConville
      Participant

      oh i think you need to login at the wp-login page, no?

    • #137397
      AvatarDavo McConville
      Participant

      >>You must be aware our WCFM plugin has not any customization in WooCommerece registration form. So, Vendor registration via WooCommerce registration form is not possible using code snippet.
      It requires serious custom development, and this will be a paid one.
      Please be advised then normal-user/customer not able to register in your site. All users will be vendors.

      Ok thanks – can you advise me on what to ask for the custom development?

      Yes, I only want users to be Vendors (because of course Vendors can also be customers, correct?)

    • #138240
      AvatarDavo McConville
      Participant

      Hello? Why is it a 4 day wait, please?

      • #138296

        Please go through our previous reply #137402, we have asked you to provide correct credentials. Without correct credential, we can not login in your site, hope you understand.

        can you advise me on what to ask for the custom development?
        >>Due to COVID-19 we are getting 400-500 more support tickets each day. So we aren’t taking any customizations at this moment. If you can wait for a couple of months then we can start your customization work. If you are interested then please contact us here – https://wclovers.com/woocommerce-multivendor-customization/

        Otherwise, It will be better to find someone who is accustom to WP development. If you face any difficulty at the time of development we will guide you accordingly.

        Thanks.

    • #138307
      AvatarDavo McConville
      Participant

      Please can you tell me how to disable all non-vendor registration?

      So that my site can only accept Vendor registrations

    • #138308
      AvatarDavo McConville
      Participant
      This reply has been marked as private.
    • #138345
      AvatarDavo McConville
      Participant

      Hi Sarmistha,

      You registered at my site, name demovendor and with your Gmail address – can I ask what page you did that on? Because it did not register you as a WCFM vendor. Thanks

    • #138449

      Hello,

      The credential you have provided us, this is not admin credentials. Without login as an admin, we are unable to see your site settings.

      Also “https://unitbase.co.uk/my-account/&#8221; ,the WooCommerce default login page is not accessible.
      Previously we have registered from here – https://unitbase.co.uk/vendor-membership/, also this URL not working at present.

      Thanks.

    • #138450
      AvatarDavo McConville
      Participant

      This is now an administrator account, please try again

    • #138454
      AvatarDavo McConville
      Participant

      The main issue right now is that the sidebar CREATE AN ACCOUNT link (that is accessed through the Login/Register at the top of the page)

      Does not function, it never redirects correctly.

      Thank you!!!

    • #138504
      This reply has been marked as private.
    • #138679
      AvatarDavo McConville
      Participant

      Thank you – everything was working perfectly yesterday. The Login/Register opened a sidepanel, and both login and register worked

      Today nothing works. I don’t understand, I haven’t changed anything

    • #138908

      Hello

      I don’t understand, I haven’t changed anything
      >>Again we checked your site, and we can see you have created too many “My account” page, then assign the wrong page in WooCoomerce “Account” page settings.
      We have selected the correct “Account” page in WooCoomerce setting and now login is working correctly.

      Please be advised it’s very difficult for us to debug your site every day if you applied wrong settings every day.
      Hope you understand.

      Thanks.

Viewing 35 reply threads
  • You must be logged in to reply to this topic.