wcfm-santa

A deal you can't resist! Get upto 35% Off on this entire cyber week.

CLAIM OFFER
00Day 02Hr 49Min 12Sec
wcfm-santa

Shop settings redirects to /my-account/

We're shifting our Forum based support to a more dedicated support system!

We'll be closing our Forum support from 10th June, 2020 and move to Email Support assistance.

  • If you are a WCFM premium add-ons user, contact us- here
  • Want to know more before buying our add-ons? Send Pre sale queries- here
  • If you are a WCFM free user, please open a support ticket at WordPress.org
  • For WCFM App related queries, reach us- here
From now the forum will be read-only!

Viewing 10 reply threads
  • Author
    Posts
    • #113933
      alexdezi
      Participant

      If a shop owner goes in the frontend dashboard -> settings he gets reidrected to /my-account/. He clicks there on dashboard and the same loop happens again.
      Whats going on?

    • #114070
      Molay Das
      Keymaster

      Hi,

      Are you using all updated versions of our plugin?
      If not please update them all and check it once. Don’t forget to take database and files backup before updating anything.

      If the issue still persists then please provide us your website login credentials and do send it as private reply here.

      Thanks,

    • #114071
      alexdezi
      Participant

      Yes, it’s all updated. I noticed when I delete the cache, it works, but it did happen again… Not sure if it’s a constant problem, for now it’s ok.

      Can you please come back to me regarding the server resources the plugin consumes? That is a really issue for me. Thanks a lot!

    • #114296
      Molay Das
      Keymaster

      Hi,

      Yes, it’s all updated. I noticed when I delete the cache, it works, but it did happen again… Not sure if it’s a constant problem, for now it’s ok.
      Please deactivate the cache plugin and check whether the issue appears again or not.

      Can you please come back to me regarding the server resources the plugin consumes? That is a really issue for me.
      Didn’t get you, can you please explain it a bit more?

      Thanks,

    • #114298
      alexdezi
      Participant

      can you have a look at this issue? https://wclovers.com/forums/topic/plugin-overloads-server-cpu-max-out/

      This unfortunately makes the plugin unusuable for some users.

      Thank you!

    • #114726
      Molay Das
      Keymaster

      Hi,

      can you have a look at this issue? https://wclovers.com/forums/topic/plugin-overloads-server-cpu-max-out/

      This unfortunately makes the plugin unusuable for some users.
      Regarding this issue I’ve replied to the respective forum link. Please contact your server admin about this issue as it seems to be a issue from your server end and do let us know what they say.

      Meanwhile if you can give me your website login details then I can check if its something else thats creating the issue.

      Please send your website login credentials as private reply here.

      Thanks,

    • #114732
      alexdezi
      Participant
      This reply has been marked as private.
      • #115009
        Molay Das
        Keymaster

        Hi,

        I’ve checked your website and its working fine. There is also very less data in this test setup and nothing installed that can create the overloads server cpu max out issue. This is an issue from hosting server end, please contact server admin for this.

        Thanks,

    • #114952
      alexdezi
      Participant

      Hi!

      Do you think this can be resolved? Will it be in an update or a code snippet? Ideally the plugin doesn’t make requests for new notifications if all the push-notifications are set off – once the site is loaded, just no new requests.
      Another question – is it possible to import shops from WC Marketplace just in case? I have 3 stores in the works and I would really need to get them started and it seems this is not an issue that can be resolved easily.

      Thank you!

      • #115010
        Molay Das
        Keymaster

        Hi,

        Do you think this can be resolved? Will it be in an update or a code snippet? Ideally the plugin doesn’t make requests for new notifications if all the push-notifications are set off – once the site is loaded, just no new requests.
        Please go to store-manager->Settings->Notification Manager and you can see the notification ON/OFF settings for different sections.

        Another question – is it possible to import shops from WC Marketplace just in case? I have 3 stores in the works and I would really need to get them started and it seems this is not an issue that can be resolved easily.
        You can use this plugin ( https://wordpress.org/plugins/wc-multivendor-marketplace-migration/ ) to migrate from WC Marketplace to WCFM Marketplace.

        Thanks,

    • #115087
      alexdezi
      Participant

      I’m afraid I was in touch with my host about this very much already. They are telling me, that the setup is making excessive admin-ajax.php requests which is bringing it down. Siteground limits the available CPU seconds. WCFM makes requests every six seconds in order to see if there are new notifications. So imagine you have 30 vendors online at the same time – each of them having 1 or 2 tabs open – and EVERY tab is making these requests – the site will go down. I know you can disable these notifications, and I have already done that. But these requests are still being made. I want shop owners only to get notifications via e-mail. I want the frontend manager, once the site is loaded, doesn’t make ANY requests to the server (or maybe 1 every 1 or 2 minutes, but not every 6 seconds).

      I also asked Siteground if an upgrade to VPS will resolve the issue – the answer was: For that amount of requests probably not. And I see on facebook groups other people with the same issue, it’s not only my sites.

      So please, give me a plain answer to: Can you disable (or manually delay the timespan to 1 minute or 2) these requests? If yes, please tell me how. If not, please just say so.

      Thank you!

    • #119175
      guidomagaldi
      Participant

      Same issue here, cpu usage overload, could you find any solution to this?

    • #122013
      alexdezi
      Participant

      Update the plugin, it should now be by default that the requests are not made…

Viewing 10 reply threads
  • You must be logged in to reply to this topic.